Fix Metasploit Update Error libssl.so.0.9.8 dan libcrypto.so.0.9.8

No Comments

Oke langsung aja, sebenernya ini udah ada di dalam skrip BT5-fixit.sh tapi ga ada salahnya dishare disini…

error ini muncul ketika melakukan update metasploit, contoh:

msfupdate

nanti akan muncul seperti ini:

[email protected]:~# msfupdate
[*]
[*] Attempting to update the Metasploit Framework...
[*]

svn: /opt/framework3/lib/libssl.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
svn: /opt/framework3/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)

Walaupun error diatas ini tidak berpengaruh terhadap keberhasilan proses update metasploit tapi cukup bikin penasaran 😛
Solusinya gampang ternyata:

cd /opt/framework/lib
mv libcrypto.so.0.9.8 libcrypto.so.0.9.8.bak
mv libssl.so.0.9.8 libssl.so.0.9.8.bak
ln -s /usr/lib/libcrypto.so.0.9.8 ./
ln -s /usr/lib/libssl.so.0.9.8 ./

keterangan:
masuk ke folder library metasploit kemudian rename file libcrypto n libssl lalu membuat simbolik link file2 tersebut dari /usr/lib, sekarang sudah fix metasploit update error libssl-so-0-9-8 dan libcrypto-so-0-9-8 kita 🙂

 

Semoga bermanfaat
iKONs